Commands and Macros

Status
Not open for further replies.

Mauzi

Status King
You should also be able to use pet names in your macros:

/pet "SuperHorse" abandon
Can't use <"> in the chat window... This is valid for many more characters like %.

Especially since you cannot copy/paste (or it doesnt use the standard keys) aswell as not scroll back through the last typed messages, this is very annoying. Maybe you like to fix this whenever you have time.

(There's more bugs in the chat too, e.g. making the UI seeming hang up since all keys at times get 'taken' by an inactive chat window. Pressing enter twice fixes this.)
 
So do exist commant in chat that unequip gear from my charachter?!
 

Mauzi

Status King
So do exist commant in chat that unequip gear from my charachter?!
If you talk about gear as in armor, I doubt so.

If it is about weapon/shield, you will just use the item a second time to unequip it, which of course only works if you have space in your backpack. For that you hardly need a command though, since dragging the weapon/shield into your hotbar is working directly.
 
Thread starter #24

Lugard

Junior Member
Can't use <"> in the chat window... This is valid for many more characters like %.

Especially since you cannot copy/paste (or it doesnt use the standard keys) aswell as not scroll back through the last typed messages, this is very annoying. Maybe you like to fix this whenever you have time.

(There's more bugs in the chat too, e.g. making the UI seeming hang up since all keys at times get 'taken' by an inactive chat window. Pressing enter twice fixes this.)
Actually I've just tested this, it appearantly does work.
That makes it much easier to setup macro's if you give your mount a default name.
 

Mauzi

Status King
Actually I've just tested this, it appearantly does work.
That makes it much easier to setup macro's if you give your mount a default name.
Odd, I tried many ways and all failed. But then, it's possible that the client and/or chat was messed up already (ever got traded while typing in the chat?).

It'd be great if this actually worked. What keys did you use to copy paste ?
 
Thread starter #26

Lugard

Junior Member
Odd, I tried many ways and all failed. But then, it's possible that the client and/or chat was messed up already (ever got traded while typing in the chat?).

It'd be great if this actually worked. What keys did you use to copy paste ?
I have to admit, I just read your post again, I quoted it mainly for the first part "Can't use <"> in the chat window", I sort of skipped over the rest initially.
I only tested that pet commands, nothing else, I don't know of anyway to copy/paste.
 
Thread starter #27

Lugard

Junior Member
Shamelessly stolen and added to the help sections ingame.
Thank you!
Glad I could help, but be sure to include Paratus's comments about the "name" bit for pet commands.
I just edited it into my post, knowing that makes it much easier for a dedicated tamer to setup his macros.
 
Thread starter #28

Lugard

Junior Member
Be warned: currently there is a small bug where your character can become unable to store macros (overuse?), but you can still use them provided that you drag them onto the hotbar before closing the Macro window.
I reported this issue and hope that it will be resolved soon.
i tried setting up a macro "/pet 1 attack" yesterday i saved it and dragn dropd to my hotbar after i close the macro window and reopen the macrowindow all the macros are GONE Oo
Just place it on your hotbar before you close and you can still use the macros, they'll fix it eventually.
 

arfus1

Senior Member
does that macro and in general pet macros work for all NEW tamed/dominated pets cuz everytime i get a new pet i need to re-drag'n drop the follow and attack icons =S seems those are only addressed to the pet ID and not pet 1, pet 2 etc.
Zergi make a macro it will then use the pet thats in that index so /pet 1 will always use the pet in index 1 . I know what you mean about dragging the attack icon over it doesnt seem to work when you change pets not sure why . But the macro will always work for whatever pet is in the index slot . btw dont forget to add the word "target " after your command in the macro otherwise it wont do anything . so a macro for pet 1 to attack your target would be .
/pet 1 attack target
 
I may be wrong as it's been a while since I worked on this, but have you tried having a number after the "feed" command? I'm pretty sure it was set up to pass an inventory slot number.
Great post Lugard. It is not functioning, take another look please, this would be so nice.
 

arfus1

Senior Member
ty fixed it and got it to work but yea as lugard said macros disapear after u close the window
Ohh dont forget to hit Apply after you make one it saves it . I have all of mine each time i log in .
 

Rimamok

Junior Member
Been playing for months and was never aware of the macro comman, there's not even an entry in the Help menu. Great thread.
 
I have been messing with the macros for a bit, and I was curious...Is there a way to add a pause in the code? It seems the game recognizes multiple entries as spam, and if we could add a pause, that would eliminate having to have multiple macros to do different things.
 

Legion138

Junior Member
I usually just use plain chat entry as a pause
 

Mauzi

Status King
If you really must macro, I suggest to use an external programmable tool. Whatever MO offers won't cut it anyways and will just be good enough to have a few hotkeys prepared. I would say that SV shouldn' invest more time into macroing than such basics - we need the work spent in other areas rather.
 
THIS! This will save me so much headache! Thank you very much Lugard and others for providing such an awesome resource. I have a feeling this will see it's way into my reportoire quite soon... Quite soon indeed! Muwahahaha. :cool:

As an aside, though still related to macros and hotbars... Am I the only one that has to redo my hotbars every danged time I login? Is there a way to get that to not be so finicky?
 

Mauzi

Status King
Yeh, there's plenty of reports about a bug that causes macros to not save reliably - they stay usable in your hotkeys though. Waiting for a fix...
 
Yeh, there's plenty of reports about a bug that causes macros to not save reliably - they stay usable in your hotkeys though. Waiting for a fix...
I'm not just talking about macros though (didn't even know how to make them till today). I'm talking about buttons for skills (like rest, sleep, etc) that completely disappear each time I log out/exit.
 

arfus1

Senior Member
THIS! This will save me so much headache! Thank you very much Lugard and others for providing such an awesome resource. I have a feeling this will see it's way into my reportoire quite soon... Quite soon indeed! Muwahahaha. :cool:

As an aside, though still related to macros and hotbars... Am I the only one that has to redo my hotbars every danged time I login? Is there a way to get that to not be so finicky?
I dont know if it will fix it but i think its worth trying running at a slightly lower res for the game .
I suggest this because i have my res reduced for running multiple clients and never seem to have
the problem with hotbars being empty at login .
 
I dont know if it will fix it but i think its worth trying running at a slightly lower res for the game .
I suggest this because i have my res reduced for running multiple clients and never seem to have
the problem with hotbars being empty at login .
I actually had some issues with the game being really laggy at medium, so I lowered it to Low. Which, given the specs of my machine (i5, 4 gigs ram, 1 gig video), that is almost a crime against computer technicians the world over. Granted, I could also see that as an excuse to upgrade, but I really doubt the buttons not saving is a hardware issue.
 
Status
Not open for further replies.
Top